import re
regex = re.compile(r"<img.+src=[\'\"](?P<src>.+?)[\'\"].*>", flags=re.IGNORECASE)
test_str = ("<table><tr><td><img src='http://newstarget.com/wp-content/uploads/sites/43/2016/10/hillary9-168x95.jpg' width='168' height='95' /></td><td valign='top'>\n"
" Many of us have been wondering exactly how Hillary Clinton has been able to get away with her blatant, obvious corruption for so long now. Even though it’s well known that the federal government protects their own and the Democrats will go above and beyond to avoid condemning a member of their party, Hillary has […] </td></tr></table>\n"
" ")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")