$re = '/(?<accountKey>\d{10})\,(?<partyKey>\d{10})/m';
$str = 'ACCOUNT_KEY,PARTY_KEY,ROLE_KEY,CHANGE_BEGIN_DATE,SEGMENT_ID,ROLE_DESC,CHANGE_END_DATE,CHANGE_CURRENT_IND
9000000001,8000001001,1,20010101,AMLKCV,,59990101,Y
9000000002,8000001002,1,20010101,AMLKCV,,59990101,Y
9000000003,8000001003,1,20010101,AMLKCV,,59990101,Y
9000000004,8000001004,1,20010101,AMLKCV,,59990101,Y
9000000005,8000001005,1,20010101,AMLKCV,,59990101,Y
9000000006,8000001006,1,20010101,AMLKCV,,59990101,Y
9000000007,8000001007,1,20010101,AMLKCV,,59990101,Y
9000000008,8000001008,1,20010101,AMLKCV,,59990101,Y
9000000009,8000001009,1,20010101,AMLKCV,,59990101,Y
9000000010,8000001010,1,20010101,AMLKCV,,59990101,Y
9000000011,8000001011,1,20010101,AMLKCV,,59990101,Y
9000000012,8000001012,1,20010101,AMLKCV,,59990101,Y
9000000013,8000001013,1,20010101,AMLKCV,,59990101,Y
9000000014,8000001014,1,20010101,AMLKCV,,59990101,Y
9000000015,8000001015,1,20010101,AMLKCV,,59990101,Y
9000000016,8000001016,1,20010101,AMLKCV,,59990101,Y
9000000017,8000001017,1,20010101,AMLKCV,,59990101,Y
9000000018,8000001018,1,20010101,AMLKCV,,59990101,Y
9000000019,8000001019,1,20010101,AMLKCV,,59990101,Y
9000000020,8000001020,1,20010101,AMLKCV,,59990101,Y
9000000021,8000001021,1,20010101,AMLKCV,,59990101,Y
9000000022,8000001022,1,20010101,AMLKCV,,59990101,Y
9000000023,8000001023,1,20010101,AMLKCV,,59990101,Y
9000000024,8000001024,1,20010101,AMLKCV,,59990101,Y
9000000025,8000001025,1,20010101,AMLKCV,,59990101,Y
9000000026,8000001026,1,20010101,AMLKCV,,59990101,Y
9000000027,8000001027,1,20010101,AMLKCV,,59990101,Y
9000000028,8000001028,1,20010101,AMLKCV,,59990101,Y
9000000029,8000001029,1,20010101,AMLKCV,,59990101,Y
9000000030,8000001030,1,20010101,AMLKCV,,59990101,Y
9000000031,8000001031,1,20010101,AMLKCV,,59990101,Y
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);