re = /(?<!\.)[a-zA-Z0-9]+(?:\.[a-zA-Z0-9]+)+[a-zA-Z0-9]$/m
str = 'For example - com.fb.test1
For example - com..fb.test.a.b.c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end