re = /"[^"\\]*(?:\\[\S\s][^"\\]*)*"|'[^'\\]*(?:\\[\S\s][^'\\]*)*'/
str = 'echo "©\\\\\\\\\\" abc " baz"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end