$re = '/\[[^][]*QUE-const[^][]*_P[^][]*]/m';
$str = 'a[15].s16.l = (xy[11].s16.l > (50/*QUE-const:VECTWord->CC_Init_P*/))
xyz = Exh[(16/*QUE-const:VECT_dir->_num_P*/) & 0x0FU ];*/))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);