import Foundation
let pattern = #"(?=[A-Z\d]*[a-z])(?=[a-z\d]*[A-Z])(?=[a-zA-Z]*[\d])[a-zA-Z\d]{6,30}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
am2Nals2kdP5 This is some sample text containing an email address of michael.knight@knightrider2000.com
and some cryptic secret like am2Nals2kdP5 and even more text. amdNalsfkdPt test am2Nals2kdP5
#$#fDD5555555
am2Nals2kdP5am2Nals2kdP5
fffddD2
am2Nals2kdP5am2Nals2kdP5
am2Nals2kdP5
am2Nals2kdf
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)