use strict;
my $str = '* <release_note_text>([*XXXBUGS-12345*]).';
my $regex = qr/\*([\w-]+)\*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";