re = /[A-Z]\w+/m
str = 'Teoretycznie tyle wystarczy, ale żeby uprzyjemnić proces pisania, fajnie jest przygotować sobie jakieś IDE (program do programowania), np. Visual Studio Code albo chociaż porządny edytor tekstu w stylu Notepad++.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end