import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Sensor #0 -> (?P<EXT>\\d+[.]\\d+)(?:.*?Sensor #2 -> )(?P<INT>\\d+[.]\\d+)(?:.*?)(?P<DATE>\\d{4}\\/\\d{2}\\/\\d{2}\\s+\\d{2}:\\d{2}:\\d{2}))";
final String string = "system tmp gettemp 0\n"
+ "Sensor #0 -> 69.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 87.81 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:50system tmp gettemp 0\n"
+ "Sensor #0 -> 69.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 88.110 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:51system tmp gettemp 0\n"
+ "Sensor #0 -> 69.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 88.206 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:52system tmp gettemp 0\n"
+ "Sensor #0 -> 69.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 87.176 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:53system tmp gettemp 0\n"
+ "Sensor #0 -> 69.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 88.110 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:54system tmp gettemp 0\n"
+ "Sensor #0 -> 69.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 88.110 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:55system tmp gettemp 0\n"
+ "Sensor #0 -> 69.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 87.176 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:56system tmp gettemp 0\n"
+ "Sensor #0 -> 69.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 87.81 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:57system tmp gettemp 0\n"
+ "Sensor #0 -> 68.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 88.15 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:58system tmp gettemp 0\n"
+ "Sensor #0 -> 68.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> system tmp gettemp 2\n"
+ "Sensor #2 -> 88.15 \n\n"
+ "OK\n"
+ "dbg_cpu0> \n"
+ "dbg_cpu0> 2016/11/23 11:04:59system tmp gettemp 0\n"
+ "Sensor #0 -> 68.0 \n\n"
+ "OK\n"
+ "dbg_cpu0> 2016/11/23 11:05:002016/11/23 11:05:012016/11/23";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}