import re
regex = re.compile(r"^(.*)\r?\n\s*\r?\nfrom:.*\r?\nsent:.*\r?\nto:.*\r?\nsubject:", flags=re.MULTILINE)
test_str = ("Hello World from: the other side of the first email\n\n"
"from: this\n"
"sent: at\n"
"to: that\n"
"subject: what\n\n"
"second email\n\n"
"from: this\n"
"sent: at\n"
"to: that\n"
"subject: what\n\n\n"
"third email\n\n"
"from: this\n"
"date: at\n"
"to: that\n"
"subject: what\n\n"
"fourth email")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")