package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)(?:/([0-9]+))?`)
var str = `https://www.statnews.com/2018/01/26/gottlieb-trump-davos/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}