$re = '/^\+?((?!\.)\d){7,23}$/';
$str = '+12.34567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);