$re = '/\[24-Jun-2021\s13:.+?(?=\n\[\d\d)/is';
$str = '[24-Jun-2021 09:15:24 America/New_York] One line data here
[24-Jun-2021 09:15:27 America/New_York] One line data here
[24-Jun-2021 09:15:31 America/New_York] One line data here
[24-Jun-2021 13:49:21 America/New_York] One line data here
[24-Jun-2021 13:49:27 America/New_York] One line data here
[24-Jun-2021 13:49:27 America/New_York] One line data here
[24-Jun-2021 13:49:28 America/New_York] Start of multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
multi-line data here
end of multi-line data here
[24-Jun-2021 13:51:16 America/New_York] One line data here
[24-Jun-2021 14:51:25 America/New_York] One line data here
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);