use strict;
my $str = '<div class="srg"><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="55"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="http://smssolutionsinc.com/" ping="/url?sa=t&source=web&rct=j&url=http://smssolutionsinc.com/&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFgg4MAA&usg=AFQjCNE3Mi7YsTWBGTd9kE6h5IHe8fB7Qg">Supplier Management Solutions</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm">smssolutionsinc.com</cite></div></div><div class="s"><div><span class="st">We are a leader in the Aerospace & Defense Industry providing "boots on the ground" <em>supplier management</em> services to major Prime and ...</span><div class="osl"><a class="fl" href="http://smssolutionsinc.com/about-sms/" ping="/url?sa=t&source=web&rct=j&url=http://smssolutionsinc.com/about-sms/&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQ0gIIOigAMAA&usg=AFQjCNGludy9IwIuvnO7EVC1WYPZQguNCQ">About SMS</a> · <a class="fl" href="http://smssolutionsinc.com/services/" ping="/url?sa=t&source=web&rct=j&url=http://smssolutionsinc.com/services/&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQ0gIIOygBMAA&usg=AFQjCNE_PhGfWVux814IQkvDBJEI9kDOzQ">Services</a> · <a class="fl" href="http://smssolutionsinc.com/contact-us/" ping="/url?sa=t&source=web&rct=j&url=http://smssolutionsinc.com/contact-us/&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQ0gIIPCgCMAA&usg=AFQjCNFRk-49soIpesiJhMHTAzHEw7Be3Q">Contact Us</a></div><div class="_Izh _UCh"><span class="_tkh _Vzh"></span><span class="_Lzh _Wzh"></span><a data-dtype="d3ph" href="javascript:void(0)" jsaction="r.LuK7zkacrsk" data-rtid="io8uFFXEYxLM" jsl="$t t-Rc2RokjmVQM$t-FqwWXB20Eac;$x 0;" class="r-io8uFFXEYxLM" data-ved="0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQkAgIPjAA"><span>(951) 676-1100</span></a></div></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="63"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="http://smssolutionsinc.com/about-sms/" ping="/url?sa=t&source=web&rct=j&url=http://smssolutionsinc.com/about-sms/&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghAMAE&usg=AFQjCNGludy9IwIuvnO7EVC1WYPZQguNCQ">About SMS | Supplier Management Solutions</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">smssolutionsinc.com › about-sms</cite></div></div><div class="s"><div><span class="st"><em>Supplier Management Solutions</em>, Inc. (SMS) was established in 2007 and is a US based leader in the Aerospace & Defense Industry providing ...</span></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="65"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="http://www.ariba.com/solutions/buy/supplier-management" ping="/url?sa=t&source=web&rct=j&url=http://www.ariba.com/solutions/buy/supplier-management&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghCMAI&usg=AFQjCNHrhg3pHRZ8ZjX2yqLqUGVty8I6cg">Supplier Management Software - Lift Performance, Cut Risk - Ariba</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">Ariba › solutions › buy › supplier-manag...</cite></div></div><div class="s"><div><span class="st">Ariba <em>Supplier Management</em> Software <em>Solutions</em>| Boost performance and cut costs and risks. All you need to know about your ...</span></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="67"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="https://www.sciquest.com/solutions/total-supplier-manager-vendor-management-software" ping="/url?sa=t&source=web&rct=j&url=https://www.sciquest.com/solutions/total-supplier-manager-vendor-management-software&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghEMAM&usg=AFQjCNFrW5-V1HFKQtfbGo4qm3XJBCRl0A">Vendor Management Software | Supplier Management Software | Total Supplier ...</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">SciQuest › solutions › total-supplier-man...</cite></div></div><div class="s"><div><span class="st">SciQuest\'s Total <em>Supplier</em> Manager is a best-in-class <em>vendor management</em> software program that incorporates upfront ...</span></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="69"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="https://www.linkedin.com/company/supplier-management-solutions-inc-" ping="/url?sa=t&source=web&rct=j&url=https://www.linkedin.com/company/supplier-management-solutions-inc-&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghGMAQ&usg=AFQjCNGLUT3FFuqtqtfihJVQyYcLqTEEhA">SUPPLIER MANAGEMENT SOLUTIONS, INC. | LinkedIn</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">LinkedIn › company › supplier-manage...</cite></div></div><div class="s"><div><span class="st">Learn about working at <em>SUPPLIER MANAGEMENT SOLUTIONS</em>, INC.. Join LinkedIn today for free. See who you know at ...</span></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="71"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="http://www.mastercontrol.com/supplier_management/solutions.html" ping="/url?sa=t&source=web&rct=j&url=http://www.mastercontrol.com/supplier_management/solutions.html&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghIMAU&usg=AFQjCNEBbhXuWnSrOaPpj62cDyYaiToLSg">Supplier Management Solutions - MasterControl</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">MasterControl › supplier_management</cite></div></div><div class="s"><div><span class="st">Manufacturers are becoming increasingly aware that <em>supplier management solutions</em> are critical to the quality management process.</span></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="73"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="https://www.capterra.com/vendor-management-software/" ping="/url?sa=t&source=web&rct=j&url=https://www.capterra.com/vendor-management-software/&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghKMAY&usg=AFQjCNE9At22QndG864A2KUhs0Hjst2nwg">Best Vendor Management Software | 2016 Reviews of the Most Popular Systems</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">https://www.capterra.com › vendor-mana...</cite></div></div><div class="s"><div><span class="st">Tipalti provides the world\'s most powerful <em>vendor</em> payments <em>management solution</em>, streamlining the entire process of <em>managing</em> ...</span></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="75"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="http://www.zycus.com/solution/supplier-management.html" ping="/url?sa=t&source=web&rct=j&url=http://www.zycus.com/solution/supplier-management.html&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghMMAc&usg=AFQjCNEvDOUGsrQmRXi9ciSnZn7M4evypw">Supplier Management Software & Supplier Performance Management Solution - Zycus</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">Zycus › solution › supplier-management</cite></div></div><div class="s"><div><span class="st">Zycus <em>Supplier Management Solution</em> - a comprehensive platform for automating all aspects of supplier performance ...</span></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="77"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="http://www.indeed.com/cmp/Supplier-Management-Solutions/reviews" ping="/url?sa=t&source=web&rct=j&url=http://www.indeed.com/cmp/Supplier-Management-Solutions/reviews&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghOMAg&usg=AFQjCNGzoavpF_zwEP7n_FuWFDbTRCIhfQ">Working at SUPPLIER MANAGEMENT SOLUTIONS: Employee Reviews - Indeed</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">Indeed › cmp › reviews</cite></div></div><div class="s"><div><span class="st">Reviews from <em>SUPPLIER MANAGEMENT SOLUTIONS</em> employees about <em>SUPPLIER MANAGEMENT SOLUTIONS</em> culture , ...</span><div class="f slp" style="clear:both"><div class="_ykm"><div class="_Uim"><div class="_wkm _ojm">Rating</div><div class="_xkm _ojm"><span><span class="_Zim">2.7</span><g-review-stars class="_Zim"><span class="_ayg" aria-label="Rated 2.5 out of 5,"><span style="width:33px"></span></span></g-review-stars><span class="_Zim">(3)</span></span></div></div></div></div></div></div></div><!--n--></div></div><div class="mnr-c"><div class="g card-section"><!--m--><div class="rc" data-hveid="80"><div class="_OXf"><div class="_fSg"><h3 class="r"><a class="_wSg" href="https://www.glassdoor.com/Overview/Working-at-Supplier-Management-Solutions-EI_IE408640.11,40.htm" ping="/url?sa=t&source=web&rct=j&url=https://www.glassdoor.com/Overview/Working-at-Supplier-Management-Solutions-EI_IE408640.11,40.htm&ved=0ahUKEwiF6-Xfz9jPAhXIQSYKHdDwBVwQFghRMAk&usg=AFQjCNE5c5639S_6tm094-9hdPLemXqrWg">Working at Supplier Management Solutions | Glassdoor</a></h3></div><div class="f kv _SWb _fof"><cite class="_Rm bc">Glassdoor › Overview › Working-at-Sup...</cite></div></div><div class="s"><div><span class="st">See what employees say it\'s like to work at <em>Supplier Management Solutions</em>. Salaries, reviews, and more - all posted by ...</span></div></div></div><!--n--></div></div></div>';
my $regex = qr/<h3 class.*[0-9][0-9][0-9][0-9]<\/span\><\/a><\/div><\/div><\/div><\/div>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}