$re = '/\*ngIf="(.*?)"/m';
$str = '*ngIf="id"';
$subst = "[visibility]=\"$1 ? 'visible' : 'collapse'\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;