re = /^[A-Z]{1,2}\s\d{4}\s([B-D]|[F-H]|[J-N]|[P-T]|[V-Z]){3}$/
str = 'whatever@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end