# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)\s+(\[[^[\]]*\]):\s*([\w\W]*?)(?=\n\n|\Z)"
test_str = ("HARPER'S [Day 1, 9:00 A.M.]: When the computer was young, the word hacking was\n"
"used to describe the work of brilliant students who explored and expanded the\n"
"uses to which this new technology might be employed. There was even talk of a\n"
"\\\"hacker ethic.\\\" Somehow, in the succeeding years, the word has taken on dark\n"
"connotations, suggestion the actions of a criminal. What is the hacker ethic,\n"
"and does it survive? \n\n"
"ADELAIDE [Day 1, 9:25 A.M.]: the hacker ethic survives, and it is a fraud. It\n"
"survives in anyone excited by technology's power to turn many small,\n"
"insignificant things into one vast, beautiful thing. It is a fraud because\n"
"there is nothing magical about computers that causes a user to undergo\n"
"religious conversion and devote himself to the public good. Early automobile\n"
"inventors were hackers too. At first the elite drove in luxury. Later\n"
"practically everyone had a car. Now we have traffic jams, drunk drivers, air\n"
"pollution, and suburban sprawl. The old magic of an automobile occasionally\n"
"surfaces, but we possess no delusions that it automatically invades the\n"
"consciousness of anyone who sits behind the wheel. Computers are power, and\n"
"direct contact with power can bring out the best or worst in a person. It's\n"
"tempting to think that everyone exposed to the technology will be grandly\n"
"inspired, but, alas, it just ain't so.\n\n"
"BRAND [Day 1, 9:54 A.M.]: The hacker ethic involves several things. One is\n"
"avoiding waste; insisting on using idle computer power -- often hacking into a\n"
"system to do so, while taking the greatest precautions not to damage the\n"
"system. A second goal of many hackers is the free exchange of technical\n"
"information. These hackers feel that patent and copyright restrictions slow\n"
"down technological advances. A third goal is the advancement of human\n"
"knowledge for its own sake. Often this approach is unconventional. People we\n"
"call crackers often explore systems and do mischief. The are called hackers by\n"
"the press, which doesn't understand the issues.\n\n"
"KK [Day 1, 11:19 A.M.]: The hacker ethic went unnoticed early on because the\n"
"explorations of basement tinkerers were very local. Once we all became\n"
"connected, the work of these investigations rippled through the world. today\n"
"the hacking spirit is alive and kicking in video, satellite TV, and radio. In\n"
"some fields they are called chippers, because the modify and peddle altered\n"
"chips. Everything that was once said about \\\"phone phreaks\\\" can be said about\n"
"them too.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.