package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^| )(?:\{|\{{3})(\w+)(?:\}|\}{3})`)
var str = `{abcd} {{efgh}} {{{ijkl}}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}