$re = '/^(?!,$)[\d,.]+$/m';
$str = '12.312,321
123.12321
1231,,2321
123123,...
.
,
,0923
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);