$re = '/([a-z].*){3,}/i';
$str = '$!@@.!x++#\'y---z,.µ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);