import re
regex = re.compile((r"^[A-Z][a-z]+([ ][A-Z][a-z]*)*$\n"), flags=re.MULTILINE)
test_str = ("Le Thanh Toan\n"
"Nuyen Thanh Toan\n"
"Le Nguyen Thanh Toan\n"
"Le Tran Nguyen Bui Huynh Thanh Toan\n"
"Le Toan\n"
"Le T\n"
"Toan\n\n"
"nguyen\n"
"nguyen nam\n"
"nguyen long \n"
"nguyen Thanh\n"
"Nguyen thanh\n"
"Le Toan \n"
"NguyeN NaM LonG")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")