import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^##\\s\\[?(Unreleased)\\]?|^##\\s\\[((0|[1-9]\\d*)\\.(0|[1-9]\\d*)\\.(0|[1-9]\\d*)(?:-((?:0|[1-9]\\d*|\\d*[a-zA-Z-][0-9a-zA-Z-]*)(?:\\.(?:0|[1-9]\\d*|\\d*[a-zA-Z-][0-9a-zA-Z-]*))*))?(?:\\+([0-9a-zA-Z-]+(?:\\.[0-9a-zA-Z-]+)*))?)\\]$";
final String string = "Valid Semantic Versions\n\n"
+ "## [Unreleased]\n"
+ "## Unreleased\n"
+ "## foo\n"
+ "## [foo]\n\n"
+ "## [0.0.4]\n"
+ "## [1.2.3]\n"
+ "## [10.20.30]\n"
+ "## [1.1.2-prerelease+meta]\n"
+ "## [1.1.2+meta]\n"
+ "## [1.1.2+meta-valid]\n"
+ "## [1.0.0-alpha]\n"
+ "## [1.0.0-beta]\n"
+ "## [1.0.0-alpha.beta]\n"
+ "## [1.0.0-alpha.beta.1]\n"
+ "## [1.0.0-alpha.1]\n"
+ "## [1.0.0-alpha0.valid]\n"
+ "## [1.0.0-alpha.0valid]\n"
+ "## [1.0.0-alpha-a.b-c-somethinglong+build.1-aef.1-its-okay]\n"
+ "## [1.0.0-rc.1+build.1]\n"
+ "## [2.0.0-rc.1+build.123]\n"
+ "## [1.2.3-beta]\n"
+ "## [10.2.3-DEV-SNAPSHOT]\n"
+ "## [1.2.3-SNAPSHOT-123]\n"
+ "## [1.0.0]\n"
+ "## [2.0.0]\n"
+ "## [1.1.7]\n"
+ "## [2.0.0+build.1848]\n"
+ "## [2.0.1-alpha.1227]\n"
+ "## [1.0.0-alpha+beta]\n"
+ "## [1.2.3----RC-SNAPSHOT.12.9.1--.12+788]\n"
+ "## [1.2.3----R-S.12.9.1--.12+meta]\n"
+ "## [1.2.3----RC-SNAPSHOT.12.9.1--.12]\n"
+ "## [1.0.0+0.build.1-rc.10000aaa-kk-0.1]\n"
+ "## [99999999999999999999999.999999999999999999.99999999999999999]\n"
+ "## [1.0.0-0A.is.legal]\n\n\n\n"
+ "Invalid Semantic Versions\n\n"
+ "## [1]\n"
+ "## [1.2]\n"
+ "## [1.2.3-0123]\n"
+ "## [1.2.3-0123.0123]\n"
+ "## [1.1.2+.123]\n"
+ "## [+invalid]\n"
+ "## [-invalid]\n"
+ "## [-invalid+invalid]\n"
+ "## [-invalid.01]\n"
+ "## [alpha]\n"
+ "## [alpha.beta]\n"
+ "## [alpha.beta.1]\n"
+ "## [alpha.1]\n"
+ "## [alpha+beta]\n"
+ "## [alpha_beta]\n"
+ "## [alpha.]\n"
+ "## [alpha..]\n"
+ "## [beta]\n"
+ "## [1.0.0-alpha_beta]\n"
+ "## [-alpha.]\n"
+ "## [1.0.0-alpha..]\n"
+ "## [1.0.0-alpha..1]\n"
+ "## [1.0.0-alpha...1]\n"
+ "## [1.0.0-alpha....1]\n"
+ "## [1.0.0-alpha.....1]\n"
+ "## [1.0.0-alpha......1]\n"
+ "## [1.0.0-alpha.......1]\n"
+ "## [01.1.1]\n"
+ "## [1.01.1]\n"
+ "## [1.1.01]\n"
+ "## [1.2]\n"
+ "## [1.2.3.DEV]\n"
+ "## [1.2-SNAPSHOT]\n"
+ "## [1.2.31.2.3----RC-SNAPSHOT.12.09.1--..12+788]\n"
+ "## [1.2-RC-SNAPSHOT]\n"
+ "## [-1.0.3-gamma+b7718]\n"
+ "## [+justmeta]\n"
+ "## [9.8.7+meta+meta]\n"
+ "## [9.8.7-whatever+meta+meta]\n"
+ "## [99999999999999999999999.9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}