$re = '/(?i)(ANSIBLE)_?(VAULT)?_?((PASS)|(PASSWORD)) ?= ?(?!(.*pass.*)|(.*secret.*)|(.*example.*)).{4,100}/m';
$str = 'ANSIBLE_VAULT_PASSWORD = "dfewat4agraggafpassgggasgsgdgasasf"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);