$re = '/(?<=Account#\s)\d+/m';
$str = 'Account# 74235873wfhufgu9897098097';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);