import re
regex = re.compile(r"^(crypto pki certificate chain TP-self-signed-.*)(?:\n(?!\1).*)*\n\1", flags=re.MULTILINE)
test_str = ("test 1 \n"
"crypto pki certificate chain TP-self-signed-1357590403\n"
" +30820330 30820218 A0030201 02020101 300D0609 2A864886 F70D0101 05050030\n"
" +31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274\n"
" +69666963 6174652D 31333537 35393034 3033301E 170D3139 30313234 31353436\n"
" +34345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649\n"
" +4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 33353735\n"
" +39303430 33308201 22300D06 092A8648 86F70D01 01010500 0382010F 00308201\n"
" +0A028201 0100E69D C133454E 401E763A 7686E453 5D58020D 0E6E122F A0F19E15\n"
" +E0975148 666110BD C1F09B86 CB701C20 EF85E024 F759A921 D11DA10C A13BA3BD\n"
" +20006387 917287CE EA0CFDDC 2FA5DD07 E5B200F4 108CACA1 DCEF0E4E EEE908ED\n"
" +2ACD693B FC90A24F 9F865CB9 859FEFB0 EB8904D4 8FA83D29 E93B892F 32F3EC7D\n"
" +EAA2850E 1793BBCE 86EA47B2 15645634 D81EA89C 1C2BC092 766DF58F 0B289A82\n"
" +0C92E551 7AA9588E F5B41A41 6DB4C785 101E674D BBBCFB42 9F4F9A25 70389515\n"
" +D1C07E2F 18C0557D 95283E90 3CCD2966 5EBF5668 A6B0B847 0B278906 E5BFA668\n"
" +EFBE938A BE70C4C0 1A8D7218 71463EA5 49540A45 DF307B4C 459E657D C039BB68\n"
" +F047B0B2 2F250203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF\n"
" +301F0603 551D2304 18301680 141FADF3 CC2C2293 810EDAA8 9E55327C D2B7D88A\n"
" +88301D06 03551D0E 04160414 1FADF3CC 2C229381 0EDAA89E 55327CD2 B7D88A88\n"
" +300D0609 2A864886 F70D0101 05050003 82010100 91E63F44 376F91C1 C50C08E4\n"
" +B29B902B B1BC7831 C5607897 030835A6 108FC1F2 6F3DEE23 EF3E8FFF 81A121B5\n"
" +26596004 F8F61DFD 1B603C5D 42D850E6 439C7CAE BFC285AE 3FD83870 125594C0\n"
" +51EAAC09 BF42446F C6399B90 D0E10ACA B208819B 645BECE5 DBDDA9AD EBA1FCD9\n"
" +2B14D0DE AB2AC1BF FF064076 ADBB4540 17AB77A4 C6B0DA3B 1BC0F5B8 44030E7B\n"
" +27318CEE 14C90739 DD8684A8 9346EEC1 3F4958EF 835BA822 F58523C9 E9F83105\n"
" +D3E68700 20DAFC5E B1B8CF5B BAC5CEB3 00321088 43125173 51FC8006 270731E6\n"
" +0E0C6183 68BABA99 BD9F4F28 1EDA82D4 F00F1359 F30B6501 BC468C89 49111AB2\n"
" +CBDE5A9D DB8DB33A 45FE6C96 7D49A70F 4C299618\n"
"crypto pki certificate chain TP-self-signed-1357590403\n"
"test 2")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)