#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((\+|00)32\s?|0)4(60|[789]\d)\/?(((\s|\.)?\d{2}){3}|((\s|\.)?\d{3}){2})$)|(^((\+|00)32\s?|0)(\d(\s|\.|\/)?\d{3}|\d{2}(\s|\.)?\d{2})((\s|\.)?\d{2}){2}$)"
Local $sString = "+32497239319" & @CRLF & _
"0032497239319" & @CRLF & _
"0032/497/13/93/19" & @CRLF & _
"0032/497.13.93.19" & @CRLF & _
"0032/497/13/93/19" & @CRLF & _
"0032497/13.93.19" & @CRLF & _
"+32497/139319" & @CRLF & _
"0497/13.93.19" & @CRLF & _
"+32497.13.93.19" & @CRLF & _
"0497139319" & @CRLF & _
"0497 13 93 19" & @CRLF & _
"0497 139 319" & @CRLF & _
"jakkamakka" & @CRLF & _
"+32497139319 OF +32497149419" & @CRLF & _
"++32497139318" & @CRLF & _
"0123456789" & @CRLF & _
"0032123456789" & @CRLF & _
"" & @CRLF & _
"036852931" & @CRLF & _
"003236852931" & @CRLF & _
"+3236852931" & @CRLF & _
"03/685.29.31" & @CRLF & _
"00323/685.29.31" & @CRLF & _
"+323/685.29.31" & @CRLF & _
"03.685.29.31" & @CRLF & _
"00323.685.29.31" & @CRLF & _
"+323.685.29.31" & @CRLF & _
"" & @CRLF & _
"03/685/29/31" & @CRLF & _
"0032/3/685/29/31" & @CRLF & _
"+32/3/685/29.31" & @CRLF & _
"03/68.529.31" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")