package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|
(\[) (?= \h* x \h* ] ) | (?<= \[ )(?= \h* x \h* (]))
)
|
(?:
(?<= \[ ) \h* (x) (?= \h* ] )
)`)
var str = `Yes: [x]
Yes: [ x]
Yes: [x ]
Yes: [ x ]
No: [x
No: x]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}