re = /([^\s.]+)\.{3}$/m
str = 'Do not match this. This sentence ends in the last word...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end