# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\-\-(.*):(.*)"
test_str = ("--font-heading: {{ settings.header_font_1_1.family }};\n"
"--font-standard: {{ settings.general_font_1_1.family }};\n\n"
" --body-font-size: {{settings.body_font_size}}px;\n"
" --font-small: 14px;\n"
" --font-medium: 17px;\n"
" --font-bold: 300;\n"
" --size-h1: {{settings.heading_size_1}}px;\n"
" --size-h2: {{settings.heading_size_2}}px;\n"
" --size-h3: {{settings.heading_size_3}}px;\n"
" --size-h4: {{settings.heading_size_4}}px;\n"
" --size-h5: {{settings.heading_size_5}}px;\n"
" --size-h6: {{settings.heading_size_6}}px;\n"
" --top-font-size: {{settings.top_bar_size}}px;\n"
" --product-font-size: {{settings.product_title_size}}px;\n"
" --product-price-size: {{settings.product_price_size}}px;\n"
" --footer-size: {{ settings.footer_font_size }}px;\n"
" {% comment %} --home-title-font-size: {{settings.home_title_size}}px; {% endcomment %}\n"
" --product-detail-title-size: {{settings.product_detail_title_size}}px;\n\n"
" --font-icon : 20px;\n"
" --font-small-icon: 21px;")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.