$re = '/^.*\\\\\[[\w\d]*?][^\\\\]*?..{4,}$/m';
$str = '"B:\\[intro & Fuck Scenes]\\[Clip] Tasty Teens - Nina.mp4"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);