import re
regex = re.compile(r"Discussion:\n(?<date>[a-zA-Z]{1,3}\s+\d{2}\/\d{2}\/\d{4}\/[^/]+)\/\s*(?<user>.*?)-?\s*\n+(?<content>.*)")
test_str = ("Discussion:\n"
"Tue 26/04/2022/2:48 PM UTC+10/ ABC User-\n\n"
"TEST description - this should be logged as a comment. --- This is the part I need\n\n"
"ABC Company Australia | XYZ St | Sydney NSW 2000")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")