import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Discussion:\\n(?<date>[a-zA-Z]{1,3}\\s+\\d{2}\\/\\d{2}\\/\\d{4}).*\\n+(?<content>.*)";
final String string = "Discussion:\n"
+ "Tue 26/04/2022/2:48 PM UTC+10/ ABC User-\n\n"
+ "TEST description - this should be logged as a comment. --- This is the part I need\n\n"
+ "ABC Company Australia | XYZ St | Sydney NSW 2000\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}