$re = '/ask_ytm=[+-]?([0-9]*[.])?[0-9]+/m';
$str = '\'=boSecBid=103.157661111boSecPop=boErrorTxt=00037CPW4: Missing Tag Information;
...: boSecParamLabel=|ask_ytm=1.16568889767|\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);