$re = '~^(?!.*\([^()]*\)).+~m';
$str = 'My name is Muds
My name is ( Muds contained )
My name is ( { Muds } )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);