$re = '/(\d{3}[^\d\w]\d{3}[^\d\w]\d{4}|\+91[^\d\w]\d{10})/m';
$str = '123-456-7891
+91 1234567891
+91-1234567891
123 456 7891
123.123 1232
123.123a1232';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);