# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+\([^()]*(((?'parenthesesPair'\()[^()]*)+((?'-parenthesesPair'\))[^()]*)+)*(?(parenthesesPair)(?!))\)"
test_str = "(PROT(MONITOR)TYPE(LCD)MODEL(MSTAR)CMDS(01 02 03 07 0C E3 F3)VCP(02 04 05 08 0B 0C 10 12 14(01(?(((i)))) 04 05 06 07 08 0A 0B) 16 18 1A 52 54(00 01) 60(00 11 12 0F 10 21 22 2F 30 31) 62 6C 6E 70 72(05 78 FB 50 64 78 8C A0) 86(01 02 08) 8D(01 02) A4 A5 AA(01 02) AC AE B6 C0 C6 C8 C9 CA(01 02) CC(02 03 04 05 07 08 09 0A 0C 0D 01 06 0B 0E 12 14 16 17 1A 1E 24) D6(01 04 05) DC(0E 00 01 02 03 05 08 0B 1F E1) DF E0(00 01 02 03 04) E9(00 02) EB(00 01 02 03) EC(00 01() 02 03) F0(00 01) F2(00 01 02 03 04) F6(01 ) F7(42 FF) F9(00 01 02 03 04) FF)MSWHQL(1)ASSET_EEP(40)MCCS_VER(2.2))"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.