import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s+(\\S+)\\s+(\\w+)\\s+\\w+\\s+\\d*\\s+\\#\\s+\\S+\\s+(?:\\d+\\s+){2}((?!.*EMPTY\\b).+)$";
final String string = "CATALYST_TH 1\n"
+ "BACKPLANE A\n"
+ "#Slot Type Serial # Rev Num Date XptA XptB Name\n"
+ " 2 879-858-35 0x0109037 A 0 # 0131-0 23 24 PLFD CC\n"
+ " 6 879-857-01 0x0253bb0 A 0 # 9517-0 15 16 PMM CC-01\n"
+ " 7 000-000-00 0x0000000 P0 0 # 0000-0 13 14 EMPTY \n"
+ " 8 000-000-00 0x0000000 P0 0 # 0000-0 11 12 EMPTY \n"
+ " 9 000-000-00 0x0000000 P0 0 # 0000-0 9 10 EMPTY \n"
+ " 10 000-000-00 0x0000000 P0 0 # 0000-0 7 8 EMPTY \n"
+ " 20 000-000-00 0x0000000 P0 0 # 0000-0 37 38 EMPTY \n"
+ " 21 000-000-00 0x0000000 P0 0 # 0000-0 39 40 EMPTY \n"
+ " 22 000-000-00 0x0000000 P0 0 # 0000-0 41 42 EMPTY \n"
+ " 23 000-000-00 0x01a2446 P0 0 # 0000-0 43 44 EMPTY \n"
+ " 1 949-669-00 0x026a850 B 0 # 0809-0 3 0 HAS (Left HAS LA669-00)\n"
+ " 13 949-668-00 0x200762d A 0 # 9530-0 0 0 CATALYST HAC\n"
+ " 12 949-667-00 0x026a4ee D 0 # 0102-0 0 0 DIF\n"
+ " 24 949-669-01 0x2006037 B 0 # 9717-0 4 0 HAS (Right HAS LA669-01)\n"
+ "END";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}