$re = '/([a-zA-Z]+(?:_[a-zA-Z]+)*)/m';
$str = '_foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);