re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])[0-9a-zA-Z!@#$%^&*?]{6,}$/
str = 'TestPassw0rd!@#$%^&*?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end