package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{(([^{}]|(?R))*)}`)
var str = `Key=key1,Value={"a=":"b"}, Key=key2,Value=value2, Key=key3,Value={"c":{"d":"e"}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}