$re = '/(?<!Mr|Dr|Ms|Jr|Sr)[.?!]+\s(?=[A-Z0-9])/';
$str = 'Mr. Smith bought cheapsite.com for 1.5 million dollars i.e. he paid a lot for it. Did he mind? Adam Jones Jr. thinks he didn\'t. In any case, this isn\'t true... Well, with a probability of .9 it isn\'t.23 is the ish. My name is! Why wouldn\'t you... this is.
Andrew';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);