#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*images\/(?!cached).*"
Local $sString = "./images/logos/partners/mastergen.png" & @CRLF & _
"./images/logos/partners/highland.png" & @CRLF & _
"./images/logos/partners/charollais.png" & @CRLF & _
"./images/logos/partners/grasstec.png" & @CRLF & _
"./images/logos/partners/stabiliser.png" & @CRLF & _
"./images/logos/services" & @CRLF & _
"./images/logos/services/farmpay-icon.png" & @CRLF & _
"./images/cached" & @CRLF & _
"./images/cached/.DS_Store" & @CRLF & _
"./images/cached/logo-farmpay-black.png" & @CRLF & _
"./images/cached/logo-green-text.svg" & @CRLF & _
"./images/cached/readme.md" & @CRLF & _
"./images/cached/logo-green-icon.svg" & @CRLF & _
"./images/cached/logo-green-icon.png" & @CRLF & _
"./images/cached/logo-farmpay-white.png" & @CRLF & _
"./images/cached/logo-white-text.svg" & @CRLF & _
"./images/cached/logo-green.png" & @CRLF & _
"./images/user" & @CRLF & _
"./images/user/.DS_Store" & @CRLF & _
"./images/user/shield.svg" & @CRLF & _
"./images/user/shield-error.svg" & @CRLF & _
"./images/user/test-delete.png" & @CRLF & _
"./images/user/locked-avatar.png" & @CRLF & _
"./images/user/unknown-avatar.png" & @CRLF & _
"./images/listing-photo-guides" & @CRLF & _
"./images/listing-photo-guides/goats" & @CRLF & _
"./images/listing-photo-guides/goats/.DS_Store" & @CRLF & _
"./images/listing-photo-guides/goats/bad" & @CRLF & _
"./images/listing-photo-guides/goats/bad/1.png" & @CRLF & _
"./images/listing-photo-guides/goats/good" & @CRLF & _
"./images/listing-photo-guides/goats/good/1.png" & @CRLF & _
"./images/listing-photo-guides/pigs" & @CRLF & _
"./images/listing-photo-guides/pigs/.DS_Store" & @CRLF & _
"./images/listing-photo-guides/pigs/bad" & @CRLF & _
"./images/listing-photo-guides/pigs/bad/2.png" & @CRLF & _
"./images/listing-photo-guides/pigs/bad/1.png" & @CRLF & _
"./images/listing-photo-guides/pigs/good" & @CRLF & _
"./images/listing-photo-guides/pigs/good/2.png" & @CRLF & _
"./images/listing-photo-guides/pigs/good/1.png" & @CRLF & _
"./images/listing-photo-guides/.DS_Store" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle/.DS_Store" & @CRLF & _
"images/listing-photo-guides/dairy-cattle/bad" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle/bad/2.png" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle/bad/3.png" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle/bad/1.png" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle/good" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle/good/2.png" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle/good/3.png" & @CRLF & _
"./images/listing-photo-guides/dairy-cattle/good/1.png" & @CRLF & _
"./images/listing-photo-guides/sheep" & @CRLF & _
"./images/listing-photo-guides/sheep/.DS_Store" & @CRLF & _
"./images/listing-photo-guides/sheep/bad" & @CRLF & _
"./images/listing-photo-guides/sheep/bad/4.png" & @CRLF & _
"./images/listing-photo-guides/sheep/bad/2.png" & @CRLF & _
"./images/listing-photo-guides/sheep/bad/3.png" & @CRLF & _
"./images/listing-photo-guides/sheep/bad/1.png" & @CRLF & _
"./images/listing-photo-guides/sheep/good" & @CRLF & _
"./images/listing-photo-guides/sheep/good/4.png" & @CRLF & _
"./images/listing-photo-guides/sheep/good/2.png" & @CRLF & _
"./images/listing-photo-guides/sheep/good/3.png" & @CRLF & _
"./images/listing-photo-guides/sheep/good/1.png" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/.DS_Store" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/bad" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/bad/4.png" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/bad/2.png" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/bad/3.png" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/bad/1.png" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/good" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/good/4.png" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/good/2.png" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/good/3.png" & @CRLF & _
"./images/listing-photo-guides/breeding-cattle/good/1.png" & @CRLF & _
"./images/listing-photo-guides/store-cattle" & @CRLF & _
"./images/listing-photo-guides/store-cattle/.DS_Store" & @CRLF & _
"./images/listing-photo-guides/store-cattle/bad" & @CRLF & _
"./images/listing-photo-guides/store-cattle/bad/2.png" & @CRLF & _
"./images/listing-photo-guides/store-cattle/bad/1.png" & @CRLF & _
"./images/listing-photo-guides/store-cattle/good" & @CRLF & _
"./images/listing-photo-guides/store-cattle/good/2.png" & @CRLF & _
"./images/listing-photo-guides/store-cattle/good/1.png" & @CRLF & _
"./images/backgrounds" & @CRLF & _
"./images/backgrounds/auctions.jpg" & @CRLF & _
"./images/backgrounds/family-cows.jpg" & @CRLF & _
"./images/backgrounds/tablet-livestock.jpg" & @CRLF & _
"./images/backgrounds/dna-strand.jpg" & @CRLF & _
"./images/backgrounds/apps.jpg" & @CRLF & _
"./images/backgrounds/.DS_Store" & @CRLF & _
"./images/backgrounds/handshake-livestock.jpg" & @CRLF & _
"./images/backgrounds/cows.jpg" & @CRLF & _
"./images/backgrounds/sheep.jpg" & @CRLF & _
"./images/backgrounds/premium-seller.jpg" & @CRLF & _
"./images/backgrounds/handshake-trade.jpg" & @CRLF & _
"./images/backgrounds/haulage-trailer.jpg" & @CRLF & _
"./images/backgrounds/uk-map.png" & @CRLF & _
"./images/backgrounds/vet.jpg" & @CRLF & _
"./images/team" & @CRLF & _
"./images/team/kate-jones.jpg" & @CRLF & _
"./images/team/michelle-shores.jpg" & @CRLF & _
"./images/team/dan-luff.jpg" & @CRLF & _
"./images/team/.DS_Store" & @CRLF & _
"./images/team/sam-scott.jpg" & @CRLF & _
"./images/team/andrew-loftus.jpg" & @CRLF & _
"./images/team/ben-stanley.jpg" & @CRLF & _
"./images/team/rosie-hetherington.jpg" & @CRLF & _
"./images/team/derek-lewis.jpg" & @CRLF & _
"./images/team/peter-ellis.jpg" & @CRLF & _
"./images/team/andrew-huxham.jpg" & @CRLF & _
"./images/team/alex-crooks.jpg" & @CRLF & _
"./images/team/bertie-steggles.jpg" & @CRLF & _
"./images/team/jamie-mcinnes.jpg" & @CRLF & _
"./images/team/patrick-bidwell.jpg" & @CRLF & _
"./images/team/dave-rose.jpg" & @CRLF & _
"./images/team/becky-smith.jpg" & @CRLF & _
"./images/team/andrew-connon.jpg" & @CRLF & _
"./images/team/karen-johnson.jpg" & @CRLF & _
"./scss" & @CRLF & _
"./scss/config" & @CRLF & _
"./scss/config/_variables.scss" & @CRLF & _
"./scss/vendor.scss" & @CRLF & _
"./scss/components" & @CRLF & _
"./scss/components/blog.scss" & @CRLF & _
"./scss/components/button.scss" & @CRLF & _
"./scss/components/table.scss" & @CRLF & _
"./scss/components/forms.scss" & @CRLF & _
"./scss/components/layout.scss" & @CRLF & _
"./scss/components/tag.scss" & @CRLF & _
"./scss/components/tooltip.scss" & @CRLF & _
"./scss/components/typography.scss" & @CRLF & _
"./scss/components/animations.scss" & @CRLF & _
"./scss/components/utility.scss" & @CRLF & _
"./scss/components/loading.scss" & @CRLF & _
"./scss/app.scss" & @CRLF & _
"./native-app" & @CRLF & _
"./native-app/generated" & @CRLF & _
"./native-app/generated/.DS_Store" & @CRLF & _
"./native-app/generated/ios" & @CRLF & _
"./native-app/generated/ios/splash" & @CRLF & _
"./native-app/generated/ios/splash/Default-568h@2x~"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")