re = /https?:\/\/.*\/\K([^#\s]+)#(\S+)/m
str = 'https://test.com/file/5gdxyYpb#_FWRc4T12baPrppZIwVQ5i18Sq16f7TXU82LJwY_BjE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end