$re = '/([\-\+]\d+)(?!\.)(?!\d)/m';
$str = '+6
-11
-177a
44
+12.5
-1.44';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);