package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+[a-z]?\.)?[ ]?(.*)`)
var str = `11a. A numbered agenda item
Unnumbered agenda item
12. Another numbered agenda item
Another UNnumbered agenda item
13. A numbered agenda item
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}