$re = '/(\d+)[^\d]+\1/';
$str = 's(-1025,1025,{32047, 32048, 32049, 32050, 32051, 32807, 32795},128)';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;