$re = '/(\n)/';
$str = 'This
is
an
example
of all newline matches.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);