use strict;
my $str = '14-5678_jobname_0123_.p1.PDF
14-5678_jobname_0123_.p2.PDF
14-5678_jobname_0125_.p1.PDF
Weired_filename_0123_bla_14-5678_jobname.p1.PDF
Weired_filename_0123_bla_14-5678_jobname.p2.PDF
Weired_filename_0125_bla_14-5678_jobname.p1.PDF
14-5678_jobname_0123.p1.PDF
14-5678_jobname_0123.p2.PDF
14-5678_jobname_0125.p1.PDF
0123_14-5678_jobname.p1.PDF
0123_14-5678_jobname.p2.PDF
0125_14-5678_jobname.p1.PDF
jobname_0123_14-5678.p1.PDF
jobname_0123_14-5678.p2.PDF
jobname_0125_14-5678.p1.PDF';
my $regex = qr/(?<=_)(\d{4})(?=_?|\.p\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}