const regex = /\b(?!^;#)\w+\s*\w+(?=[?^(|)]\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!^;#)\\w+\\s*\\w+(?=[?^(|)]\\b)', 'gm')
const str = `-1;#Class Study|0b4dac95-9e17-4af9-b849-6d283a99b561;#-1;#Matrix|dda77641-7b25-40f9-bb65-a0bca13776d3";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}