// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[ABCEGHJKLMNPRSTVXY][0-9][ABCEGHJKLMNPRSTVWXYZ] ?[0-9][ABCEGHJKLMNPRSTVWXYZ][0-9]").unwrap();
let string = "K1G 6C9
K1G 6C9---
K1G 6C9====
K1G 6C9K1G 6C9
K1G 6C9K1G 6C9K1G 6C9
K1G 6C9slkdjfsdklfjsdkjfhsdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}